Codemagic CI/CD - GitHub has intermittent issues which leads to SWW errors in builds – Incident details

All systems operational

GitHub has intermittent issues which leads to SWW errors in builds

Resolved
Degraded performance
Started 4 days agoLasted about 6 hours

Affected

Third Party: GitHub → API

Degraded performance from 4:45 PM to 11:00 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Identified
    UTC
    Identified

    According to GitHub status page, there are issues that GitHub is currently investigating. Builds use tools and libraries that are installed from GitHub therefore sometimes fail to start, however our monitoring systems show that the failure rate is quite low. We will post an update as soon as the issue is resolved.