Codemagic CI/CD - Linux and Windows builds queued because of GCP resource exhaustion – Incident details

All systems operational

Linux and Windows builds queued because of GCP resource exhaustion

Resolved
Partial outage
Started about 13 hours agoLasted about 11 hours

Affected

Linux machines

Partial outage from 9:53 PM to 8:30 AM

Windows machines

Partial outage from 9:53 PM to 8:30 AM

Updates
  • Resolved
    Resolved

    We switched to an alternative working zone, and builds are running normally.

  • Investigating
    Investigating

    New Linux and Windows build VM creation failed due to resource exhaustion in GCP zone us-east1-d. Affected builds were queued but not started.