Codemagic CI/CD - Linux and Windows builds failing because of 3rd party connectivity issues – Incident details

All systems operational

Linux and Windows builds failing because of 3rd party connectivity issues

Resolved
Partial outage
Started 2 days agoLasted 11 minutes

Affected

Linux machines

Partial outage from 4:00 PM to 4:12 PM

Windows machines

Partial outage from 4:00 PM to 4:12 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We’ve identified the GitHub API servers respond with "504 Gateway Timeout" which is causing builds to fail with SWW on start. The issue is confirmed by the GitHub status page. So far, only a few builds have been affected.