Codemagic CI/CD - Google infrastructure is down for us – Incident details

All systems operational

Google infrastructure is down for us

Resolved
Major outage
Started 13 days agoLasted about 5 hours

Affected

macOS machines

Operational from 5:46 PM to 7:19 PM, Degraded performance from 7:19 PM to 10:51 PM

Linux machines

Operational from 5:46 PM to 7:19 PM, Degraded performance from 7:19 PM to 10:51 PM

Windows machines

Operational from 5:46 PM to 7:19 PM, Degraded performance from 7:19 PM to 10:51 PM

App Preview

Operational from 5:46 PM to 10:51 PM

CodePush server

Operational from 5:46 PM to 10:51 PM

Updates
  • Resolved
    Resolved

    Although the Google Cloud status page still reports ongoing incidents with some services, our monitoring tools indicate that builds are running normally and are no longer affected. As a result, we are marking this incident as resolved.

    We will continue to monitor the situation and provide updates if anything changes. Thank you for your patience.

  • Update
    Update

    Some APIs that our service depends on are still experiencing errors. As a result, you may encounter “Something Went Wrong” message during builds. We are closely monitoring the situation and will resume normal operations as soon as these external services are fully restored.

    Thank you for your patience and understanding.

  • Monitoring
    Monitoring

    The earlier outage affecting our services due to a Google Cloud issue appears to be resolved. Our systems are coming back online, and we are actively monitoring to ensure everything is running smoothly.

    Please note that some users may experience longer build queue times as we work through the backlog. We appreciate your patience and understanding.

  • Identified
    Identified
    We are currently experiencing a service outage due to an issue with our underlying infrastructure provider, Google Cloud. Our team is actively monitoring the situation and working with Google to restore service as quickly as possible. We apologize for the inconvenience and appreciate your patience. Updates will be provided as soon as more information is available.