Codemagic CI/CD - We are observing elevated 429 errors while downloading Maven dependencies – Incident details

All systems operational

We are observing elevated 429 errors while downloading Maven dependencies

Resolved
Degraded performance
Started 17 days agoLasted 2 days

Affected

macOS machines

Operational from 10:00 AM to 10:00 AM

Linux machines

Operational from 10:00 AM to 10:00 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    Sonatype has whitelisted Codemagic's IP addresses to avoid rate-limiting issues, and we are currently monitoring the results. Thank you for your patience!
  • Identified
    Identified
    Sonatype, the company behind Maven, has introduced new network-wide usage policies that have impacted multiple organizations and CI/CD providers. You can read more in their blog post: We recommend enabling the Gradle cache to avoid downloading the same artifacts repeatedly. If your release flow is still blocked, please contact our support team - we can provide further guidance.